Kleiner Fragen Katalog

  • Ich hab da mal wieder ein Problem :

    Railworks 64 bit lässt sich nicht mehr starten.

    Anfangs kam MSVCR100.dll fehlt

    dann 0xc000007b

    die 32bit Version läuft .

    Was hab ich gemacht ?

    Tune up 2019 deinstalliert und blöderweise die Visual C Versionen bis 2017 gleich mit .

    Die Visual C hab ich alle wieder installiert, die Vorschläge im Wiki alle durch , Das Spiel neu installiert(vor visual C - könnte es daran liegen?),lokale Dateien auf Fehler prüfen

    und im Internet nach diesem Fehler gesucht . Alles bis hier vergebens.

    Ich stehe auf dem Schlauch ...

  • Tja , das hab ich alles durch und es kommt bei der 64bit Version immer die 0xc... Meldung.


    Ich überlege gerade nochmals den TS zu de und wieder zu installieren ,nachdem jetzt Visual C von 07 -19 alle drauf sind

    Edited once, last by Mike38239: Ein Beitrag von Mike38239 mit diesem Beitrag zusammengefügt. ().

  • ja , hab ich .


    -------------------------------

    So und nochmal TS2021 deinstall und install durchgezogen, Fehler bleibt.

    Warum nur 64 Bit , alle anderen Spiele funktionieren bis jetzt.

    Ich bin Ratlos , wäre das ein Win10 Fehler müssten doch andere Programme auch betroffen sein , oder nicht ?*ka*

  • Neuer Versuch:

    Kompletten Railworks-Ordner auf Externe Platte verschoben und abgeklemmt.

    Nun Neu -Install des Simulators in Sauberer Version. Hoffen und Zittern, Hoffen und Zittern....


    ...und wieder nicht . Immer noch sofort nach Starten der 64bit Version :0xc000007B Fehler .

    Edited once, last by Mike38239: Ein Beitrag von Mike38239 mit diesem Beitrag zusammengefügt. ().

  • "tuneup" oder "wie zerschieße ich mir meine registry so, dass garnix mehr läuft" mal ehrlich jetzt wer nimmt das denn heute noch?

    Da kann man sich auch selbst ins Bein schiessen.


    vorsicht beim rum-und num schieben...es gibt paywareinstaller die installieren nur auf "c" darum empfehle ich bei viel payware "installieren auf c" des TS. ( aber das nur am rande)


    ich empfehle system neu aufsetzen ( also win 10 xxxx ) und ts neu. erspart einem das langtäge rumfummeln.

  • Quote

    vorsicht beim rum-und num schieben...es gibt paywareinstaller die installieren nur auf "c" darum empfehle ich bei viel payware "installieren auf c" des TS. ( aber das nur am rande)

    Äh , ja . Ich bin verwirrt. :)


    Es ist ja nicht so das gar nichts mehr läuft , nur TS 64 bit zickt rum.

  • es gibt paywareinstaller die installieren nur auf "c" darum empfehle ich bei viel payware "installieren auf c" des TS.

    Dann frag ich mich warum der TS samt Payware auf G läuft? Bei der IKBv3 ist das glaub noch so, der sucht Steam und nicht den TS. 99% der installer suchen den TS.


    Mike38239 bitte einmal unten links in die Suchleiste "cmd" eingeben. Erscheint dann links das Fenster, mit der rechten Maustaste auf die Eingabeaufforderung drauf und als Admin ausführen.

    Wenn du das gemacht hast, müsste sich die Konsole öffnen. Ist diese auf, gib mal "sfc/SCANNOW" ein. Dann wird dein PC komplett gecheckt und Windows sucht fehlerhafte Dateien und repariert diese.

    So biste jedenfalls sicher ob du dann ein Problem mit dem PC hast. Ist das aber auch ohne Ergebnis, der TS stürzt immernoch ab, versuche es mal mit diesem hier:

    https://support.microsoft.com/…ea-4433-9aff-95f26a218cc0

    Gehts dann immernoch nicht, hat dir TuneUP ganz schön im System rumgefummelt.

    Eins fällt mir noch ein, haste mal die Setup.Audio.bat im Railworks Verzeichnis ausgeführt?

  • Dieses Audio-Setup.bat-Dingens ist nach meiner Kenntnis seit TS2020 überflüssig. Der TS nimmt sich automatisch die korrekte OpenAL-Datei.

    Weichenzungen haben wenig zu sagen, sind dafür aber richtungsweisend.

  • Das Audio Teil hab ich mehrfach laufen gehabt.

    in der Konsole CMD.exe bin ich , gebe sfc/scannow ein und bekomme die Antwort ich müsse als Admin angemeldet sein ?!

    Mein Rechner nur ein Benutzer und normal sollte ich der Admin sein ?! Oder nicht?

    Hab vor lauter Verzweiflung schon Windows mit CD reparieren wollen , ein Update auf die neueste Version verpasst bekommen und

    der Fehler besteht weiter (zwischendurch war auch der Elite-Watchdog betroffen -konnte durch Installation der aio-runtimes_v2.5.0 (1)´wieder zum laufen gebracht werden.)


    Bei mir liegt der RailWorks auch auf Laufwerk H - da hab ich 500GB Platz zum "spielen"


    Hab jetzt den ganzen Tag im System rumgegraben und gesucht und mir raucht die Birne. PC muss laufen , wenn nicht , laufe ich .

    Ich werde mal ne Pause einlegen und ne Weile Elite Dangerous spielen , schaue aber immer wieder hier rein (nur nicht wundern ,das nicht sofort eine Antwort kommt)

    Edited 2 times, last by Mike38239: Ein Beitrag von Mike38239 mit diesem Beitrag zusammengefügt. ().

  • Hast Du nach der TS-Installation auch die Programme in LW:\Program Files (x86)\Steam\steamapps\common\RailWorks\Install\

    aufgerufen?

    0xc000007B Fehler

    Dieser tritt meines wissens auf, wenn das Net-Framework nicht korrekt installiert ist.

    Das wäre im oben genannten Ordner die Datei dotNetFx40_Full_x86_x64.exe!

  • Ja , schon mehrfach , wobei immer gemeldet wird es wäre eine neuere Version schon vorhanden.


    gerade nochmal versucht , "Version 4 ist schon vorhanden..."


    Net-Framework deinstallieren ? Kann da was defekt sein ?

    Edited 2 times, last by Mike38239: Ein Beitrag von Mike38239 mit diesem Beitrag zusammengefügt. ().

  • Ja , wenn ich denn das Eingabefenster aktiv gehabt hätte :wacko:

    aber nu gräbt Er das System um ...


    Repairing file \??\C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\\mscormmc.dll from store


    Warning: Overlap: Directory \??\C:\ProgramData\Microsoft\Windows\Start Menu\ is owned twice or has its security set twice

    Original owner: Microsoft-Windows-shell32, version 10.0.19041.746, arch amd64, nonSxS, pkt {l:8 b:31bf3856ad364e35}



    Aber ich hoffe das dieser Satz der wichtigste ist:

    Verify and Repair Transaction completed. All files and registry keys listed in this transaction have been successfully repaired


    Aber leider ist der Fehler noch vorhanden;(


    Sollte danach ein Neustart gemacht werden ?

    Edited 3 times, last by Mike38239: Ein Beitrag von Mike38239 mit diesem Beitrag zusammengefügt. ().

  • Gibt es sonst noch etwas was den TS64 daran hindert zu starten , den 32er aber normal arbeiten lässt?

    (Das Suchprogramm hat beim zweitem Durchgang übrigens nichts mehr gefunden)

  • Eine fehlende/defekte/veränderte Datei die für ihn im 64-Bit Modus nötig ist. Solange man aber nicht eine art Gamelog, Errorlog oder sonstiges hat, ist ein 6'er mit Zusatzzahl wahrscheinlicher als den Fehler zu finden.

    Don't believe what your eyes are telling you, all they show is limitation, look with your understanding.

    Wer für Meinungsfreiheit ist, muss auch andere Meinungen aushalten.

  • Ich würde die

    dotNetFx40_Full_x86_x64.exe!

    noch einmal deinstallieren und (falls vorhanden fremde, nicht windowseigene Virenscanner abschalten) danach erneut installieren. Und das unabhängig von eventuell anderen dotNet-Versionen!

  • Unter welchem Namen ist das denn gelistet ,ich finde das nicht in meiner Softwareliste , Bekomme beim Installieren diese Meldung:



    Details


    Microsoft .NET Framework 4 ist bereits Bestandteil dieses Betriebssystems. Sie müssen .NET Framework 4 Redistributable nicht installieren. <A HREF="http://go.microsoft.com/fwlink/?LinkId=164207">Weitere Informationen</A>.


    Dieselbe oder eine höhere Version von .NET Framework 4 wurde bereits auf diesem Computer installiert.



    Ich hab da Version 4.8 gefunden