Train Simulator stürzt ab auf Freiburg Basel Reloaded

  • Hallo liebe Community,


    ich habe mir für die Strecke Freiburg Basel Reloaded die beiden Szenarien Eurocity nach Altona und Walter fährt nach Freiburg hier aus dem rail sim Forum installiert.


    Hier die Links der Szenarien:


    https://rail-sim.de/forum/wsif…-Freiburg-Basel-Reloaded/
    https://rail-sim.de/forum/wsif/index.php/Entry/4520-ES-Walter-fährt-nach-Freiburg/


    Leider tritt bei beiden Szenarien das Problem auf, dass nach einiger Zeit das Bild plötzlich einfriert. Ich kann dann nichts anderes mehr machen, als den Rechner neu zu starten.
    Manchmal tritt der Fehler früher auf und manchmal kann ich etwas länger mit meinem Spielerzug fahren.


    Woran kann dieses Problem liegen? Nach welcher Art von Fehler soll ich suchen?


    Vielen Dank schon mal für Tipps!
    Martin

  • Spielst du in der 32bit oder in der 64bit-Version des TS?


    Fehlermeldung (ev. nach dem Einfrieren mit Alt-Tab auf den Desktop wechseln, falls dort vielleicht eine Meldung erschienen ist)?


    Systemdaten (Grafikkarte, Prozessor, RAM, usw.)?

  • Ich spiele in der 64 bit Variante.


    Meine Grafikkarte ist NVIDIA GTX 1080, ich habe Intel Core i7 7700 und 16GB RAM. Windows 10


    Auf den Desktop wechseln geht nicht, ich sehe dann nur die Taskleiste unten, das Bild des TS bleibt. Eine Fehlermeldung gibt es nicht.
    Ich drücke dann Strg Alt + Entf und fahre dann den Rechner herunter.

  • Das liegt weder an der Original noch an der Reloaded Variante, sondern schlichtweg an einer unglücklichen Kombination eurer PC`s und dem 64bit TS.


    Einige haben egal ob High End Kiste oder Aldi PC ständig Probleme mit Abstürzen oder kamen mit Einführung der 64bit keinen Meter weiter als ins TS Menü. Andere wie ich z.b hatten
    bisher nicht einen einzigen Absturz während der Fahrt! Dies zeigt ja das es funktioniert, aber eben die Kombination aus PC und TS entscheidend ist, also irgendwie ein Glücksspiel...


    Abstürze im Editor habe ich übrigens auch massenhaft, liegt bei der 32bit Version an der alten RAM Grenze und bei der 64bit an was weiss ich, aber dem kann man ja durch regelmässiges
    abspeichern entgegen wirken. Es ist leider wie es ist und da man seit dem Release der 64bit Version kein hilfreiches Update bekam, kann man davon ausgehen das sie selbst nicht wissen
    wo es hängt...

  • Hatte damals zu Beginn die selbigen Probleme mit dem TS 2019 64 Bit .


    Hatte mich dann zur Neuinstallation entschieden mit den 3th Entwickler AddOns inbegriffen seit dem habe ich ruhe.
    Keine Abstürze großartig mehr und dieses Einfrieren sehr schlimm bei vR Loks auch nicht mehr.

  • Hallo. Probiert doch bitte mal die "OpenAL32.dll" in der 32-Bit-Variante, auch wenn ihr im 64 Bit TS spielt. Wechselt die mit der "Setup_Audio.bat" ganz einfach mal aus. Das brachte bei mir die Lösung für dieses Problem. Vorher hatte ich auch immer dieses Einfrieren. Irgendwelche Nachteile beim Sound habe ich auch noch nicht herausgefunden.

  • An der Stelle auch noch einmal der Hinweis darauf, dass sich die "OpenAL32.dll" in der 64 bit Version wohl nicht
    sonderlich mit der Soundausgabe über USB verträgt.


    Über USB angeschlossene externe Soundkarten, Audiointerfaces und Kopfhörer können für das Einfrieren verantwortlich sein.


    Ich selbst hatte ein Audiointerface per USB angeschlossen. Ständig fror der TS nach kurzer Zeit ein.
    Nachdem ich auf die interne Soundkarte umgestellt hatte, war das Problem gelöst.


    Ein Kollege aus dem Forum hatte das gleiche Problem mit einem Kopfhörer den er per USB mit seinem Rechner
    verbunden hatte. Auch hier war das Problem nach dem umstellen auf die interne Soundkarte gelöst.

    Gruß Jörg!


    Das Licht am Ende des Tunnels, könnte auch ein Gegenzug sein *ka*

    Edited once, last by Raytracer ().

  • "Setup_Audio.bat" ausführen und die 1) auswählen für TS 32 Bit. Dann ganz normal 64 Bit TS starten und ausprobieren. Meiner Meinung nach ist die 64 Bit Version von der "OpenAL32.dll" fehlerbehaftet, siehe zB Beitrag von Raytracer. Danke dafür, sehr interessant. Ich nutze eine interne Creative Soundkarte, kann schon sein, dass es daran liegt. Aber die "OpenAL32.dll" in der 32-Bit-Version funktioniert bei mir bestens.

  • @Thaddäus


    Da hast du vollkommen Recht. Die Erfahrung habe ich auch gemacht.


    In der 32 Bit Version funktioniert die "OpenAL32.dll" klaglos auch mit der
    Soundausgabe per USB.

    Gruß Jörg!


    Das Licht am Ende des Tunnels, könnte auch ein Gegenzug sein *ka*

  • guten morgen und erst mal ein gesundes neues an alle...also sonst muss ich sagen hatte ich bisher kaum abstürzen gehabt...hier aus dem Download Bereich...und orginal Strecken auch nicht mehr...


    Wo finde ich denn die set up Audio bat datei?
    Die starte ich dann für die 32bit Version und wähle dann per Steam die 64bit zum starten habe ich das richtig verstanden? :)

  • Also ich habe jetzt mal den Tipp von @Thaddäus ausgeführt, und es hat Erfolg gezeigt! Ich habe bisher das Szenario Eurocity 6 nach Altona getestet und dieses Mal konnte ich es durchspielen, also kein Einfrieren des Bildes. Super! An der Stelle nochmals vielen Dank!


    Ich werde natürlich auch noch andere Szenarien testen!


    @Polotuner33 :
    Die Datei Setup_Audio , von der @Thaddäus in Beitrag 11 spricht, findest Du im Railworks Verzeichnis. Diese mit rechter Maustaste anklicken, im Kontextmenü auf Öffnen gehen. Danach im DOS Fenster die Ziffer 1 für 32bit TS eintippen, dann Return. Nun das Fenster schließen.
    So habe ich es getan.


    Am Ende dann in Steam den 64bit TS starten.


    Frohes neues Jahr! Martin

  • Vielen Dank Martin das hat mir sehr geholfen ich werde jetzt mal testen....und dann bericht erstatten.


    Auch den anderen natürlich vielen dank für eure hilfe.


    Eine frage hätte ich noch wie kann ich denn hier ein neues thema öffnen???

  • Und jetzt soll DTG nochmal kommen und das Problem auf die User schieben. Ich war DTG gegenüber lange neutral gestimmt, aber dass man die Fehler vom TS 19 nun gar nicht mehr angeht, finde ich fast schon ne Frechheit. Stattdessen immer mit Neuinstallation kommen.


    Den Nachteil der 32 Bit Version habe ich gelesen, aber ist nun mal besser wie wenn dauernd das Bild einfriert. Will nicht wissen, wie viele User die Lust verlieren, weil der TS andauernd abstürzt und das nur, weil die 64 Bit Version von dieser dämlichen dll genommen wird, wohlgemerkt auf Vorschlag von DTG. Bei mittlerweile vielen Fällen, diese dll betreffend: Quod erat demonstrandum.


    DTG soll mal bei all ihrem TSW Enthusiasmus den Code vom TS 64 Bit nochmal unter die Lupe nehmen.

  • friert mein bildschirm weiter ein

    ....es wäre ja dringend nötig, dass alle die das Problem auf normalen Strecken haben, sich bei DTG melden, sonst bekommt DTG nie mit, dass das Problem wohl viele betrifft. Schwierig ist es allerdings wenn es - wie hier -eine veränderte Strecke betrifft, da ist ein DTG Support wohl schwer möglich.

    PC-Daten und ein TS Einstellungen siehe Profil