TS on new gaming laptop

  • I have a new gaming laptop with newest generation i7, 1TB M2 SSD, 16GB RAM and RTX 3070 8GB. TSW and other games are running lightening fast, but TS is a problem. Firstly, I can only run TS in 32bit, with excellent frame rates, but then have to live with CTD's when using heavy scenarios. If I try to run TS in 64bit, I end up with a stuttershow. Anyone in here running TS successfully 64bit on a laptop?


    Second problem: With Konstanz-Villingen, Hausach-Konstanz and Frankfurt U-Bahn, all the tunnels are suddenly like daylight inside. Could this be caused by the Nvidia drivers for the new generation RTX cards? Everything mentioned here works fine on my stationary PC, which use the RTX 2070 Super 8 GB.


    PS, moderators, please move this thread to TS-Bereich.

  • No, the problem here is that your Lpatop starts the game on its internal graphics on the CPU, not on the GPU. Go into the Nvidia settings and add the 64 bit exe to it. Then configure it to use the RTX3070 there

  • BlackyTrains


    Thanks, that did the trick. I reset the graphic settings to default, then made my usual modifications anew.


    klimi15,


    That sounds sensible, I'll give it a try and get back to you later. You're saying I should use the Nvidia control panel to set all the graphic settings with the TS 64bit exe instead of using the TS internal settings?

  • No, you need to assign your special RTX 3070 graphics card to Train Simulator. By default the game will run off the integrated graphics processor and you will need to change that in the Nvidia control panel. The 3070 might be listed as an "Nvidia high performance processor" (that's how it is in my case). Select that and save it as the default for running Train Simulator in 64 bit.

    Heute hier, Morgen hier, Übermorgen eventuell dort

  • Norweger

    Added the Label resolved