Switch changes position while still running over it? / Weiche bewegt weil ich nog daruber fahr?

    • Switch changes position while still running over it? / Weiche bewegt weil ich nog daruber fahr?

      Hallo,

      I have another strange problem. It took me a while to find what caused a derailment driving into a yard. Halfway through passing the switch with a consist I got a derailment everytime. *shau*

      It turns out that the switch changes position when I am still on it!
      If needed I can make a video but maybe someone has seen this before?

      What causes it? Can I fix it?

      I hope someone knows :D
      "It's not about perfection, it's about progress"
      Werbung
    • I don't know your exact situation - but i assume you are talking about some scenario, where some AI trains (and the Railworks dispatcher) are involved.

      Maybe your own train started short (e.g. only loco) and you coupled some cars, making for a longer train?
      Then maybe the reason is, that the dispatcher doesn't know your real train length, because she calculates the length in the beginning
      (i stumbled across this situation while making a quickdrive scenario for some other route).

      If this is the situation, maybe you can start with a longer t rain, initially decoupling the cars.
    • You are exactly right! It is in a scenario with AI traffic and I start with only a little diesel engine. I then couple 20+ wagons and run the route...

      Is the switch changing because some AI train is on it's way, therefore switching the switch back? Then I can maybe just delete that AI train because it is on the end of my scenario anyway.
      Or is the switch just returning to it's standard (straight) position even without an AI train influencing it?

      If removing AI traffic doesn't work I will have to use your suggestion and start with a longer consist...

      Thanx for your quick reaction Nobsi! I would have never guessed....

      Paul
      "It's not about perfection, it's about progress"
    • I had this problem with a scenario, too.
      In my case the dispatcher switched the junction always under my last wagon for another AI train.
      I could prevent this issue by either:
      driving very very slowly thru this junction, so I had to simulate a building site ("Langsamfahrstelle")
      or
      by starting the scenario with a complete consist, instead of a single loko, which couples wagons later in the scenario.
      Ist es denn wirklich so schwer, das "DASS" und das "DAS" richtig einzusetzen? das-dass.de/
    • But this should not happen if the train is still in the same signal block.
      Schuster told me to check the signalling links to prevent an error ("open" or "corrupt" signal block).
      But there wasn't any error and the dispatcher switched the junction ~20 metres BEFORE my last wagon hits the signal link.

      There is another possibility which could cause such bugs.
      What if the length of one or more wagons are faulty with a too small length in the BIN files?
      Therefore the dispatcher "thinks" the consist has passed completely but it hasn't in reality yet.
      Ist es denn wirklich so schwer, das "DASS" und das "DAS" richtig einzusetzen? das-dass.de/
    • Maybe it is worth doing some testing to find out what the exact problem is here.

      After checking my signals I could first try another wagon type and see what happens. Thus confirming or ruling out bin.file issues
      Then play with AI traffic timing and routing to see if that influences the issue.

      If I can't get it to work with these methods I will change the scenario starting with a long consist.

      "The devil is in the details" certainly goes for Railworks! :wacko:
      "It's not about perfection, it's about progress"
    • It was not the wagons, it was AI traffic switching the switch in combination with the 'loco only' scenariostart.

      I changed the AI traffic so that the train causing the switch to move reaches it's destination before I enter the yard.

      This fixed it. I really didn't want to change the scenariostart and the traffic was only moving out of sight so this solution works best for me ^^

      On we go with changing station names now...
      "It's not about perfection, it's about progress"
      Werbung