Google Earth Overlay auch ohne Kreditkarte benutzen.

    • Google Earth Overlay auch ohne Kreditkarte benutzen.

      Hallo Zusammen.

      Für alle die es vieleicht noch nicht wissen, es gibt ein Trick, wie man Google Earth Overlay im TS Verwenden kann auch ohne Kreditkarte.
      Der Trick besteht da drin, das man ein Proxy verwendet, der anfragen von static maps umbiegt auf einen anderen Service.
      Gefunden hab ich das via Steam im Community Forum, und bei mir funktioniert das sehr gut, wenn man sich an die englische Anleitung halten tut.

      Hier ist der Link dazu.
      steamcommunity.com/sharedfiles/filedetails/?id=1500125545

      Keine angst der Proxy sollte eh nur laufen wenn man mit dem TS Editieren will, und der Sourcecode sieht sauber aus.

      Lg aus Düsseldorf
      Wutknubbel
      Bitte schaut nicht so auf meine Rechtschreibung, ich gebe mein bestes, habe aber eine angeborene Rechtschreibschwäche.
      Werbung
    • Na toll, jetzt hab ich mir extra eine Kreditkarte beantragt *haumichweg* .

      Aber danke dir für den Hinweiss, ich wäre sonst echt verrückt geworden. Muss nur nochmal den Thread suchen, wo neulich die DEM Schritte erklärt wurden *achtung*

      The post was edited 1 time, last by BR430 ().

    • Die Tage kommt noch ein Tutorial wie man RWDecal wieder zum laufen bekommt, zumindest zu 99%

      Muss nur nochmal ne VM aufsetzen und die schritte Verifizieren, und ne gescheite Anleitung schreiben :)
      Bitte schaut nicht so auf meine Rechtschreibung, ich gebe mein bestes, habe aber eine angeborene Rechtschreibschwäche.
    • Hallo Zusammen,

      super Arbeit und Hinweise von Wutknubbel, auch das RWDecal wieder laufen wird. Wenn Google Earth Overlay im Train Simulator auch ohne Kreditkarte angewendet werden kann, ist dies für mich die einfachere Art und Weise. Bei der Verwendung von RWDecal hatte ich in der Vergangenheit das Problem, dass ich beim Bau die Kacheln hin und wieder aus versehen verschoben habe. Da kam mir die Lösung mit Earth Overlay als die Unterstützung beim Streckenbau genau richtig. Irgendwie komme ich mit den Anweisungen aus dem angegebenen Link nicht klar.

      Es wäre super, wenn jemand noch die Zeit findet, eine Anleitung Schritt für Schritt mit den entsprechenden Links und Einstellungen hier bereitstellen kann. Nach der Anleitung im angegebenen Link bekomme ich es nicht zum "Laufen". *hilfe*
    • Hallo

      Train_SG wrote:

      Es wäre super, wenn jemand noch die Zeit findet, eine Anleitung Schritt für Schritt mit den entsprechenden Links und Einstellungen hier bereitstellen kann. Nach der Anleitung im angegebenen Link bekomme ich es nicht zum "Laufen". *hilfe*
      Als Erstes Brauchst du Node.js in der Version 8.11.3 die bekommst du hier : nodejs.org/dist/v8.11.3/
      Desweiteren noch das ProxyScript von : github.com/Ren-Chang/trainsim-map-proxy

      Nun Installierst du dir das Node.js und danach entpackst du das Script in einen Beliebigen Ordner.

      Jetzt Öffnest du die CommandLine oder Powershell und navigierst zu dem Ordner wo du das script entpackt hast.
      Dort startest du dann node app.js, nun sollte das script sich melden mit running on port 6789

      Nun noch fix die Internet einstellungen von windows öffnen und dort die Proxyeinstellungen suchen.
      Dort haken wir Setupscript verwenden an und geben als scriptadresse 127.0.0.1:6789/pac.txt ein


      Ist alles geschehen sollte TrainSimulator beim starten Den Proxy nehmen statt Google Earth direkt.

      Bitte noch drauf achten.


      Settings in TS bei Google Maps :

      Auflösung 640x640 (1280) geht nicht

      Typ Hybrid

      Zoom 3 letzte Stufe


      Habs gerade mit dem TS 2020 getestet und es geht, manchmal muss man den TS neu starten bis es klappt.

      Ich schau die Tage nochmal rein,muss den rechner mal wieder Frisch aufsetzen.
      Sollte es dann immer noch nicht Klappen, schau ich mal Ob ich eine Bilder Anleitung mache, oder gleich 2 Videos Erstelle, jenachdem was mein Rechner zulässt.
      Bitte schaut nicht so auf meine Rechtschreibung, ich gebe mein bestes, habe aber eine angeborene Rechtschreibschwäche.
      Werbung

      The post was edited 1 time, last by Wutknubbel: Ergänzung ().

    • Also bei mir mecker mein PowerShell und sagt: images does not yet support your current enviroment: windows 64-bit with unsupported runtime

      The post was edited 1 time, last by BR-218: Bitte keine Vollzitate verwenden. Ein @ und Usernamen reichen da auch vollkommen aus. ().

    • Ehrlich gesagt bin ich bei der Fehlermeldung da auch ein bischen Überfragt.

      Ich habe mal mein Ordner gepackt und eine Deutsche Anleitung gemacht mit ein paar Bildern.
      Habs nochmal ausprobiert sogar mit dem TS2016.

      Der Download sollte hoffentlich bald Freigeschaltet werden, dann findet ihr den hier im Download Bereich unter TrainSimulator : Editoren&Tools.

      Viel spass damit
      Bitte schaut nicht so auf meine Rechtschreibung, ich gebe mein bestes, habe aber eine angeborene Rechtschreibschwäche.
    • Super Anleitung. Die Installation der Programmteile und auch die Einstellungen im Proxy waren recht einfach und nachvollziehbar.
      Mit dem Zusatz in der Readme-Datei

      "BugFix: by Wutknubbel (wk)
      07102019-1100 - changing line 41 res.sendfile('./gmaps.pac') is deprecated using new sendFile.."

      hilft mir bei meinen fehlenden Grundkenntnissen nicht weiter. Ich habe mir die Datei "gmaps.pac" einmal im Editor geöffnet, konnte aber keine line41 finden.
      Im Train Simulator habe ich weiterhin nur die blauen Kreise, egal ob Roadmap oder Hybrid.

      Trotzdem ein großes Lob und Dankeschön an Wutknubbel für die Übersetzung und sehr detaillierte Anleitung.
    • Danke für das Lob.

      Der Eintrag ist nur ein Hinweis, das ich in der app.js bei zeile 41 ein bugfix gemacht habe, weil das res.sendfile Deprecated (Veraltet) wahr
      und deshalb manchmal node.js eine fehlermeldung ausgegeben hat.

      Der fehler mit den Blauen Kreisen habe ich zwischendurch auch mal.
      Bei mir hilft dann, den TS Beenden, einmal den Browser aufmachen und ne internet adresse eingeben, dann sollte in der eingabeaufforderung
      eine Meldung kommen, das er die gpac.txt verwendet, dann sollte es auch wieder im TS Gehen.
      Bitte schaut nicht so auf meine Rechtschreibung, ich gebe mein bestes, habe aber eine angeborene Rechtschreibschwäche.
    • Ich muß mal fragen, wie genau man das installiert? Es gibt ja keine .exe Datei. In der readme steht: Node.js installieren. Wo ist diese Datei? Ich hab mir das hier aus dem DL Bereich geladen.

      MfG Picnic

      Edit:
      Habs hin bekommen und es geht sogar. :thumbsup:

      The post was edited 1 time, last by Picnic ().

    • Also, ich hatte ja schon im Projektthread bei mir geschrieben, dass das Google Maps Overlay bei mir absolut nicht mehr will. Hab jetzt eine Woche dran gesessen und kein Erfolg in Sicht. Auch nicht mit der Methode die hier beschrieben wurde, das Javascript und der Proxy ansich laufen bei mir ohne Fehlermeldung, nur nach Neustart tut sich im TS nichts, auch nach aufrufen einer Seite im FF.

      Ich habe probeweise schon die Firewall im Windows deaktiviert, um zusehen ob dort etwas geblockt wird, aber auch da keine Änderung, Resultat immer nur blaue Kreise - keine Projektion der Kacheln aus Google Maps.

      Im Vorfeld auch schon mehrmals den TS deinstalliert und wieder neuinstalliert und immer mit gleichen Ergebnis, mein Windows10 wurde gerade erst vor 3 Wochen frisch aufgesetzt und ist auch nicht zugemüllt. Ich bin mit meinen Latein am Ende - eine Rückkehr nach RWDecals würde ich des Aufwands wegen gerne vermeiden, geschweige denn ob es überhaupt noch lauffähig zu bekommen ist ohne Google Earth 6.0.

      Hat hier jemand Hintergrundwissen, wie der TS im "Overlay Modul" genau und welcher Datei bzw. API den Google Server abfragt?

      PS: Auch habe ich 2 gültige API Keys, mit deren ich natürlich versuche vorrangig die Geschichte wieder ans Laufen zu bekommen. Die Einschränkung bei Google auf http gesetzt und die Abfragen für Static Maps, Javascript Maps und Embbed Maps eingestellt.

      The post was edited 1 time, last by rschally ().

    • New

      Hallo,

      möchte vermelden, das mein Google Maps Overlay wieder funktioniert. Nach langen Suchen in der Google Dev Console habe ich dann eine Fehlermeldung in meinen Account gefunden, welcher besagte, das mein Benutzerrechnungskonnto nicht aktiv sei und hab wie ein Blöder den Button zum Aktivieren des Kontos gesucht und schließlich fündig geworden.


      Wichtig ist auch zu kontrollieren dass, das Projekt aktiv ist :


      Hier mal eine kleine Check Liste für User, die ein Rechnungskonto bei Google mit hinterlegter Kreditkarte haben :

      1. API Key in der player_proflies.bin checken, ob korrekt eingetragen.
      2. Im Google Konto checken, ob die Static Maps Api aktiviert ist,kann man in der Kopfzeile sehen anhand grünen Kreis mit weißen Haken.
      3. Unter Zahlungsmethoden checken, ob die Kreditkarte nicht abgelaufen und die Daten aktuell sind, wenn nicht entsprechend aktualisieren.
      4. Wie oben schon gezeigt, checken ob das Rechnungskonto aktiv und nicht geschlossen ist (was bei mir der Fall war).


      Das sollte es eigentlich sein, andere Darstellungsprobleme können sonst nur von Google Maps selber kommen oder in gewissen Bereichen sind nicht alle Zoomstufen verfügbar, ich hoffe - vielleicht hilft es andere bei der Fehlersuche des Google Maps Overlay. ;)

      The post was edited 2 times, last by rschally ().

    • New

      Wirklich eigenartig.
      Mein GE-Overlay funktioniert wie gehabt genauso wie sonst auch.
      Ich musste weder Kreditkartendaten noch sonstwas bemühen. Auch nicht diese kuriosen Tipps hier.
      Ist genauso wie immer.

      Es wird wohl nicht daran liegen, dass Google mich besonders lieb hat, sondern muss andere Gründe haben.
      Ist es denn wirklich so schwer, das "DASS" und das "DAS" richtig einzusetzen? das-dass.de/