Sounds der TTB Szenario Packs zu laut

    • Sounds der TTB Szenario Packs zu laut

      Hallo zusammen,

      nachdem sowohl Google als auch die foreninterne Suche mir nicht weitergeholfen hat, folgende Frage:

      Vor kurzem habe ich mir die beiden hervorragenden Szenario Packs von TTB für Berlin-Wittenberg und München-Augsburg geholt, unter anderem um die tollen Szenarios der Community hier fahren zu können. Beide Packs finde ich richtig gut, insbesondere in München ohne Ruckeln, dass macht richtig Freude. Die Sounds finde ich auch gut, allerdings ist in meinen Augen die Lautstärke der Güterwagen viel zu hoch. Der ist zwar passend, wenn man neben dem Gleis stehen würde (also z.B. Aussenansicht), allerdings habe ich das gleiche Niveau an Lautstärke, wenn ich im Führerstand bei 200 fahre. Dass führt unter anderem dazu, dass ich in diesen Momenten quasi nichts mehr von meinem eigenen Zug bzw. meiner eigenen Lok höre, inklusive SiFa, PZB und LZB. Kennt einer von Euch vielleicht eine Möglichkeit, die Lautstärke der Sounds zu reduzieren (z.B. um ca. 50%)? So habe ich mich auch gewundert, dass ich bei den Güterzug-Szenarien hinter mir den Güterzug deutlich habe Rumpeln und Scheppern gehört habe. Wenn ich auf einer recht lauten ELok mit aktiven Lüftern fahre, würde ich auch da erwarten, dass von den Güterwagen kaum etwas zu hören ist. Für mich wäre daher etwas weniger deutlich mehr.

      Vielen Dank schonmal für Eure Antworten.

      In diesem Sinne,
      Euer Sumner
      Werbung
    • MrSumner schrieb:

      allerdings habe ich das gleiche Niveau an Lautstärke, wenn ich im Führerstand bei 200 fahre.
      Normalerweise wird im Cab einer Lok die Lautstärke reduziert. Wenn das bei dir nicht der Fall ist, hast du entweder gerade eine schlechte Lok erwischt (bei der diese "Cab Occlusion" fehlt), oder du hast in den TS Sound-Einstellungen EFX ausgeschaltet.

      edit:
      oder das was Prelli verlinkt :)
      (war mir noch nicht aufgefallen, weil ich TTB Güterwagen vor allem stehend benutze)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von nobsi ()

    • Danke schonmal für Eure Antworten. Es bringt mich einer Lösung vielleicht etwas näher. So wie ich das sehe, ist Maiks Erklärung möglicherweise der Schlüssel zur Lösung des Problems. So naiv wie ich bin werde ich jetzt einfach mal versuchen, anstelle "Inside" in den Sound-Blueprints "Both" einsetzen. Ich werde in Kürze berichten, ob und in wie weit dass eine Lösung sein kann. Alternativ bleibt vielleicht auch mit Hilfe der Informationen von Christrains (danke hierfür) die Möglichkeit, die Gesamtlautstärke ein wenig herab zu setzen. Allerdings hoffe ich, dass bereits eine Änderung auf "Both" das plötzliche Scheppern in ein etwas realistischeres Ergebnis verändert.


      @Prelli: Du weißt nicht zufällig, wie die User das gemacht haben? Ggf. kann mir auch einer von denen weiter helfen? Bereits erledigt, Siehe Edit 2. Danke nochmals!

      Edit 2:

      Mittlerweile habe ich mir mal in den entsprechenden soundproxy.xml der Güterwagen alle Eintragungen wie oben geschildert angepasst. Um es kurz zu machen: Das Ergebnis ist vielversprechend, genau so wie ich es mir vorgestellt habe. Anstatt der plötzlichen lauten Fahr- und Stoßgeräusche hört man nun auf dem Führerstand lediglich ein dumpfes Grollen. Je nach Entfernung zwar durchaus immer noch relativ laut, aber weit entfernt von dem, was mich ursprünglich die Frage hat stellen lassen. Ich werde jetzt erstmal noch ein paar weitere Szenarien fahren, um sicher zu gehen, dass das auch wirklich bei beiden Szenariopacks funktioniert und meine Anpassungen ggf. auch auf die Personenzüge ausweiten. Diese klingen zwar nicht ganz so verkehrt, aber bestimmte Geräusche sollten auch bei denen eigentlich nur gedämpft zu hören sein. Ich werde dann nochmal entsprechend berichten.

      Wenn Interesse besteht, schreibe ich hier auch gerne eine kurze Anleitung für die Interessierten. Ist eine relativ schnell gemachte Änderung in den Dateien, die aber die Immersion deutlich verbessern. Dann sind die Szenariopacks vielleicht doch noch was für Dich @Prelli.

      Beste Grüße,
      Sumner

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von MrSumner () aus folgendem Grund: Rechtschreibung + fehlerhaften Link bearbeitet. Statusupdate

    • So, sorry für den Doppelpost, ich denke aber, dass die Anleitung so besser zu finden sein wird:

      Wem die Güterzüge von TTB ebenfalls zu laut sind, hier nun eine kurze Anleitung, wie das behoben werden kann. Ihr benötigt dafür ein Programm, mit dem ihr XML-Dateien öffnen und bearbeiten könnt (beispielsweise "Word" oder "Wordpad"), sowie ein Programm, mit dem ihr .AP-Dateien öffnen könnt, wie beipielsweise Winrar.

      Im Kern scheint das Problem der lauten Güterzüge dadurch verursacht zu werden, dass der TS 2016 glaubt, den Ton der Außenansicht auch in der Innenansicht abspielen zu müssen. Die entsprechende Anweisung in der XML wirkt sich aber auf "alle" Innenansichten aus, so dass der gleiche Sound aus der Außenansicht immer abgespielt wird, egal ob Innen- oder Außenansicht aktiv ist. Mit dieser Anleitung könnt ihr dem TS erklären, dass er auf die Sounds die Cab Occlusion anwendet.

      Die zu bearbeitenden Dateien findet ihr unter "Eurem Installationsverzeichnis/.../Railworks/Assets/TrainTeamBerlin".


      Wichtig: Macht unbedingt eine Sicherheitskopie dieses Ordners, falls Euch die Anpassung nicht gefällt oder Fehler verursacht.


      Je nachdem, ob ihr Vol.1, Vol.2 oder beide der Szenariopacks installiert habt, gibt es zwei Ordner, die für die Sounds der Güterwagen relevant sind:

      1.) "TTB_GW_st"
      2.) "TTB_GWagSound"

      Ordner Nr. 1 beinhaltet "TTB_GW_st.ap", die ihr mit Winrar oder ähnlich öffnen müsst. Ordner Nr. 2 ist bei mir entpackt gewesen, also braucht ihr hier kein Winrar. Ihr findet dann einen Ordner "Audio", in dem die Änderungen durchgeführt werden müssen. In diesem Ordner befinden sich viele Dateien und weitere Ordner, wir interessieren uns aber nur für die .proxyxml - Dateien (z.B. TTB_Gwag_Container.proxyxml). Diese öffnet Ihr nun mit dem Textbearbeitungsprogramm Eurer Wahl. Zunächst werdet ihr von viel Text erschlagen sein, mit der "Suchen & Ersetzen"-Funktion mancher Textprogramme ist die ganze Angelegenheit aber schnell erledigt: (Nochmal zur Erinnerung: Sicherheitskopie!) Aktiviert nun die "Suchen&Ersetzen"-Funktion.

      In die Suchzeile kopiert ihr: INSIDE</PlayState>
      In die Ersetzen-Zeile kopiert ihr: BOTH</PlayState>



      Achtet darauf, exakt die hier angegebene Schreibweise anzuwenden, sonst könnten Teile der .proxyxml verändert werden, die nicht geändert werden sollen. Anschließend klickt ihr auf "Alle Ersetzen". Anschließend speichert ihr die Datei, schließt das Programm wieder und bestätigt noch, dass Winrar die Datei im Verzeichnis erneuern soll. Das wiederholt ihr nun für jede .proxyxml in beiden Ordnern #1 und #2.


      Abschließend könnt ihr nun eine Testfahrt unternehmen und Euch an der neuen, viel realistischeren Soundkulisse auf dem Führerstand freuen. In der Außenansicht verändert sich hingegen nichts, bleibt also alles wie gehabt. Gefällt Euch die Änderung nicht, einfach mit der Sicherheitskopie alle gemachten Änderungen überschreiben.



      Mit der gleichen Technik könnt ihr natürlich auch alle anderen Sounds der KI-Züge umschreiben. Allerdings waren die wahrnehmbaren Änderungen eher klein, so dass ihr Euch den Aufwand in meinen Augen sparen könnt.



      Vielen Dank an alle, die mir dabei geholfen haben zu verstehen, wie der TS 2016 mit Sounds umgeht.



      In diesem Sinne allzeit gute Fahrt!
      Euer Sumner



    • So ich krame das hier mal aus, weil ich noch etwas hinzuzufügen habe:

      Die Antleitung von @MrSumner funktioniert zwar, aber die Sounds überlappen sich in der Außenansicht, was manchmal etwas komisch klingt. Von daher gibt es noch eine aufwendigere Lösung:

      Man lösche alle "inside" Einträge (siehe Schritt 1.png) und tauscht "OUTSIDE</PlayState>" gegen "BOTH</PlayState>" (siehe Schritt 2.png). Bei der Bogie-Datei ist dies ähnlich.




      Ich bin nicht wirklich gut im erklären, aber vielleicht hilft es dem einen oder anderen weiter. :D

      Klappt übrigens auch bei den IC und n-Wagen. Wenn euch überlappende Sounds in der Außenansicht nicht stören, reicht auch die Anleitung im Post 5.
      Achja und Sicherheitskopie natürlich nicht vergessen.

      Eigentlich würde ich mir ja wünschen, wenn der Entwickler da noch was machen würde. Also @BigBenjy und Team, die Sound sind wirklich super, aber sie sind anscheinend völlig falsch eingebunden, so dass die CabOcclusion überhaupt nicht funktioniert und die entgegenkommenden Güterzüge (und auch ICs sowie n-Wagen) sich einfach völlig unrealistisch anhören (also vom Führerstand aus). Die Dostos haben dagegen im Cab garkeinen Rollsound.

      Hier wurde ja der Grund und die Lösung schon genannt.
    • Ah ja da hat sich auch jemand Gedanken gemacht. Weiter so das gefällt mir. :thumbup:
      Wenn man in Deutschland die Wahrheit sagt, macht man sich unbeliebt, denn viele wollen unbequeme Wahrheiten nicht hören.
      Die Wahrheit ist nämlich politisch nicht korrekt und somit auch nicht gesellschaftsfähig.
      Werbung
    • Man muss dafür die Wagen nicht abklappern das geht ganz anders. Es ist so einfach wenn man sich mal etwas Zeit nimmt und dahinter klemmt.

      Edit...Hab ich bei mir schon lange abgeändert. Wo wir wieder beim Thema sind ..alles für Nüppes abgreifen andere sollen sich kümmern und Gedanken machen und das dann kostenlos hier einstellen.
      Und wenn dann was nicht funktioniert weil der Anwender nicht klar kommt noch Support leisten.
      Wenn man in Deutschland die Wahrheit sagt, macht man sich unbeliebt, denn viele wollen unbequeme Wahrheiten nicht hören.
      Die Wahrheit ist nämlich politisch nicht korrekt und somit auch nicht gesellschaftsfähig.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Madison ()

    • ja proxyxml ändern reicht aus dann ist das Problem als solches erledigt. INSIDE lahmlegen und die OUTSIDE auf BOTH setzen.

      Edit..Das nur mal als allgemeine Anleitung für die Leute die verstehen worum es hier überhaupt geht. Je nach Paket was man von TTB hat muss man das entsprechend aus der ap Datei extrahieren und entsprechend ändern und wiederum ausserhalb der ap ablegen. Ich denke mal das ich weitere Erklärungen hier nicht abgeben brauch denn wer bis jetzt ohnehin nur Bahnhof verstanden hat wird hier nicht weiter kommen.
      Wenn man in Deutschland die Wahrheit sagt, macht man sich unbeliebt, denn viele wollen unbequeme Wahrheiten nicht hören.
      Die Wahrheit ist nämlich politisch nicht korrekt und somit auch nicht gesellschaftsfähig.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Madison ()

    • Hallo Community

      Ich krame mal wieder einen alten Post hervor weil ich dazu eine Frage habe:

      Es gibt in den genannten Dateien einen Abschnitt "loop" und einen Abschnitt "oneshot".

      Kann (muss) man bei beiden Abschnitten den Eintrag "inside" löschen und in der ganzen Datei alle "OUTSIDE</PlayState>" gegen "BOTH</PlayState>" ersetzen?

      Danke im Voraus für die Info.